GoPHP5

The end of days for PHP 4 is fast approaching. I’m not sure how much longer the developers of PHP will continue to create releases for PHP 4.x, but I do know that there is a movement in place to move to PHP 5.2+. That movement is at GoPHP.org. The idea is that by February 5th, 2008, all participating projects and hosts will have a minimum PHP version requirement of 5.2. Their website has a list of projects and web hosts that have agreed to participate. I strongly suggest checking it out and doing such things yourself.

Over the past summer, I was able to update the Cornell College webservers to PHP 5 (from PHP 4.2.3). While this did cause a few problems with some of our older scripts, overall, it has given us significantly more versatility in creating and maintaining usable code. All applications that I develop, both for Cornell and for my own enjoyment, have been written for PHP 5.